现在的位置: 首页 > 综合 > 正文

HDU1142:A Walk Through the Forest(Dijkstra+dfs)

2013年01月02日 ⁄ 综合 ⁄ 共 2287字 ⁄ 字号 评论关闭
Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest,
and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from
B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 
 


Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test
case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection
b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 
 


Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 


Sample Input
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 


Sample Output
2 4

 

题意:从1走到2有最短路为定值,求最短路有几条

思路:先求出最短路,然后搜索求出最短路的条数

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int inf = 999999999;
int map[1005][1005];
int dis[1005],vis[1005];
int path[1005];
int n,m;

void Dijkstra(int src)
{
    int i,j,minn,pos;
    memset(vis,0,sizeof(vis));
    for(i = 0; i<=n; i++)
        dis[i] = map[src][i];
    dis[src] = 0;
    vis[src] = 1;
    for(i = 1; i<=n; i++)
    {
        minn = inf;
        pos = 0;
        for(j = 1; j<=n; j++)
        {
            if(minn>dis[j] && !vis[j])
                minn = dis[pos = j];
        }
        vis[pos] = 1;
        for(j = 1; j<=n; j++)
            if(dis[j]>dis[pos]+map[pos][j] && !vis[j])
                dis[j] = dis[pos]+map[pos][j];
    }
}

int DFS(int src)
{
    if(path[src] !=-1)
        return path[src];
    if(src == 2)
        return 1;
    path[src] = 0;
    for(int i = 1; i<=n; i++)
    {
        if(dis[i]<dis[src] && map[i][src]!=inf)
            path[src]+=DFS(i);
    }
    return path[src];
}

int main()
{
    int i,j,x,y,z;
    while(~scanf("%d",&n),n)
    {
        scanf("%d",&m);
        for(i = 0; i<=n; i++)
        {
            for(j = 0; j<=n; j++)
                map[i][j] = inf;
            map[i][i] = 0;
        }
        for(i = 0; i<m; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            map[x][y] = map[y][x] = z;
        }
        Dijkstra(2);
        memset(path,-1,sizeof(path));
        printf("%d\n",DFS(1));
    }

    return 0;
}

 

 

抱歉!评论已关闭.