现在的位置: 首页 > 综合 > 正文

HDU4247:A Famous ICPC Team

2014年03月05日 ⁄ 综合 ⁄ 共 1320字 ⁄ 字号 评论关闭
Problem Description
Mr. B, Mr. G, Mr. M and their coach Professor S are planning their way to Warsaw for the ACM-ICPC World Finals. Each of the four has a square-shaped suitcase with side length Ai (1<=i<=4) respectively. They want to pack their
suitcases into a large square box. The heights of the large box as well as the four suitcases are exactly the same. So they only need to consider the large box’s side length. Of course, you should write a program to output the minimum side length of the large
box, so that the four suitcases can be put into the box without overlapping.
 


Input
Each test case contains only one line containing 4 integers Ai (1<=i<=4, 1<=Ai<=1,000,000,000) indicating the side length of each suitcase.
 


Output
For each test case, display a single line containing the case number and the minimum side length of the large box required.
 


Sample Input
2 2 2 2 2 2 2 1
 


Sample Output
Case 1: 4 Case 2: 4
Hint
For the first case, all suitcases have size 2x2. So they can perfectly be packed in a 4x4 large box without wasting any space. For the second case, three suitcases have size 2x2 and the last one is 1x1. No matter how you rotate or move the suitcases, the side length of the large box must be at least 4.
 

 

水题了,给出四个正方体箱子的边长,问能装下这四个正方体箱子的大正方体边长最小要多大

要边长最小且必须能装下四个箱子,呢么这四个箱子肯定要叠放两层才行,所以边长以最长的两个小正方体边长而定

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int main()
{
    int a[4],cas = 1;
    int x,y,ans;
    while(~scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3]))
    {
        sort(a,a+4);
        printf("Case %d: %d\n",cas++,a[2]+a[3]);
    }

    return 0;
}

 

抱歉!评论已关闭.