现在的位置: 首页 > 综合 > 正文

POJ 2632 Crashing Robots 模拟

2014年01月22日 ⁄ 综合 ⁄ 共 3245字 ⁄ 字号 评论关闭
Crashing Robots
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4679   Accepted: 2052

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots
occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the
robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in
the NS-direction.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.

Figure 1: The starting positions of the robots in the sample warehouse


Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of
  • L: turn left 90 degrees,
  • R: turn right 90 degrees, or
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case:
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4 
5 4 
2 2 
1 1 E 
5 4 W 
1 F 7 
2 F 7 
5 4 
2 4 
1 1 E 
5 4 W 
1 F 3 
2 F 1 
1 L 1 
1 F 3 
5 4 
2 2 
1 1 E 
5 4 W 
1 L 96 
1 F 2 
5 4 
2 3 
1 1 E 
5 4 W 
1 F 4 
1 L 1 
1 F 20 

Sample Output

Robot 1 crashes into the wall 
Robot 1 crashes into robot 2 
OK 
Robot 1 crashes into robot 2 

题意:

某个仓库很高科技 用机器人搬东西,告诉你机器人的个数 仓库的大小 给你一些让机器人转向或者移动的命令 让你判断机器人在执行这些命令的时候 会不会相撞或者撞墙。

 

注意 题中的 仓库坐标 原点在左下角、、让我改半天 - -

1Y。。感觉爽哇、

思路:

赤裸裸的模拟吧、没什么好说的;

#include <iostream>
using namespace std;
const int M = 110;
int map[M][M];
int xy[4][2]={{0,-1},{1,0},{0,1},{-1,0}};
bool reported;
int A,B,n,m;
struct Robot
{
	int x, y;
	int d;
}r[M];

int dir(char d)
{
	if(d=='S') return 0;
	if(d=='E') return 1;
	if(d=='N') return 2;
	if(d=='W') return 3;
}
void move(int id, int times)
{
	int d = r[id].d;
	map[r[id].x][r[id].y]=0;
	for(int i=0; i<times; i++)
	{
		r[id].x += xy[d][0];
		r[id].y += xy[d][1];
		if((!r[id].x||r[id].x>A) || (!r[id].y||r[id].y>B))
		{
			reported = true;
			printf("Robot %d crashes into the wall\n", id);
			return ;
		}
		if(map[r[id].x][r[id].y]!=0)
		{
			reported = true;
			printf("Robot %d crashes into robot %d\n", id, map[r[id].x][r[id].y]);
			return ;
		}
	}
	map[r[id].x][r[id].y] = id;
}
int main()
{
	int i,t,id,times;
	char d;
	scanf("%d", &t);
	while(t--)
	{
		memset(map, 0, sizeof(map));
		reported = false;
		scanf("%d %d", &A, &B);
		scanf("%d %d", &n, &m);
		for(i=1; i<=n; i++)
		{
			scanf("%d %d %c", &r[i].x, &r[i].y, &d);
			r[i].d = dir(d);
			map[r[i].x][r[i].y] = i;
		}
		for(i=0; i<m; i++)
		{
			scanf("%d %c %d",&id, &d, ×);
			if(d=='F' && !reported) move(id, times);
			else if(d=='L' && !reported)
			{
				times %=4;
				r[id].d = (r[id].d+times)%4;
			}
			else if(d=='R' && !reported)
			{
				times %= 4;
				r[id].d = (r[id].d-times)%4;
				if(r[id].d<0) r[id].d +=4;
			}
		}
		if(!reported) printf("OK\n");
	}
	return 0;
}

 

【上篇】
【下篇】

抱歉!评论已关闭.