现在的位置: 首页 > 综合 > 正文

HDU 1069 Monkey and Banana

2014年03月22日 ⁄ 综合 ⁄ 共 2909字 ⁄ 字号 评论关闭

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4975    Accepted Submission(s): 2548

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall
be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
 

Recommend
JGShining
 解题思路:类似于最长上升子序列,把箱子拆成3*n个,这样相当于把一个箱子分成高度不同的3个,按底面积从小到大排好,根据转移方程dp[i]=max{dp[j]}+c[i](1<=j<i&&a[i]>a[j]&&b[i]>b[j]),其中dp[i]表示前i个箱子能堆起的最大高度。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct R
{
	int a;
	int b;
	int c;
	int s;
}r[200];
bool cmp(R a,R b)
{
	return a.s<b.s;
}
int main()
{
	int m=1,n,i,j,k,l,w,h,dp[200],temp,ans;
	while(scanf("%d",&n)!=-1&&n)
	{
		ans=0;
		memset(dp,0,sizeof(dp));
		k=1;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d%d",&l,&w,&h);
			r[k].a=l;r[k].b=w;r[k].c=h;r[k].s=r[k].a*r[k].b;
			k++;
			r[k].a=w;r[k].b=l;r[k].c=h;r[k].s=r[k].a*r[k].b;
			k++;
			r[k].a=h;r[k].b=l;r[k].c=w;r[k].s=r[k].a*r[k].b;
			k++;
			r[k].a=h;r[k].b=w;r[k].c=l;r[k].s=r[k].a*r[k].b;
			k++;
			r[k].a=l;r[k].b=h;r[k].c=w;r[k].s=r[k].a*r[k].b;
			k++;
			r[k].a=w;r[k].b=h;r[k].c=l;r[k].s=r[k].a*r[k].b;
			k++;
		}
		sort(r+1,r+k,cmp);
		dp[1]=r[1].c;
		for(i=1;i<k;i++)
		{
			temp=0;
			for(j=1;j<i;j++)
				if(r[i].a>r[j].a&&r[i].b>r[j].b&&temp<dp[j])
					temp=dp[j];
			dp[i]=temp+r[i].c;
		}
		for(i=1;i<k;i++)
			if(ans<dp[i])
				ans=dp[i];
		printf("Case %d: maximum height = %d\n",m++,ans);
	}
	return 0;
}

抱歉!评论已关闭.