现在的位置: 首页 > 综合 > 正文

POJ 1401 Factorial

2014年03月23日 ⁄ 综合 ⁄ 共 2398字 ⁄ 字号 评论关闭
Factorial
Time Limit: 1500MS   Memory Limit: 65536K
Total Submissions: 12530   Accepted: 7792

Description

The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest
signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.

ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying
this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called "Travelling Salesman Problem" and
it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4....N. The number is very high
even for a relatively small N.

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour
of the factorial function.

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1 < N2, then Z(N1) <= Z(N2). It is because
we can never "lose" any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.

Input

There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output

For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input

6
3
60
100
1024
23456
8735373

Sample Output

0
14
24
253
5861
2183837

Source

Central Europe 2000

解题思路:对于给定的正整数,求其阶乘的结果的末尾0共有多少个,对于一个十进制数,只有可以分解成2*5的形式末尾才能有添0,即是说一个数的阶乘中可以拆分出多少对2*5,阶乘结果中末尾就有几个0,又5的个数显然小于2的个数,所以拆分的结果中有几个5就是最后答案;实际上,在每从1开始的24个数之间只能拆出4个5,25可以拆出2个5;50,75,100,...均可拆出2个,知道这些规律,就直接看代码吧。

#include <iostream>
using namespace std;
int f(int n)
{
    int k=0;
    while (n>=5)
    {
        n/=5;
        k+=n;
    }
    return k;
}
int main()
{
    int t,n;
    cin >> t;
    while (t--)
    {
        cin>>n;
        cout<<f(n)<<endl;
    }
    return 0;
}

 

抱歉!评论已关闭.