现在的位置: 首页 > 综合 > 正文

POJ 1276 Cash Machine

2014年03月23日 ⁄ 综合 ⁄ 共 2591字 ⁄ 字号 评论关闭
Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20922   Accepted: 7335

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination
Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers
in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of
requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered
cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

Source

Southeastern Europe 2002

解题思路:多重背包问题,利用二进制的思想将某种物品的k个物品转化为1,2,2^2,2^3,... ... ,2^n个加上剩下不能被2整除的物品合编为一个,这样该物品就从k个转化为x个2^n个物品加上多余的一组的和,这样可以保证所有物品都可以表示为某几个转化后物品的和的形式,对所有转化后的物品讨论取或不取即可,这样就把多重背包转化为01背包问题(具体可见背包九讲的内容)。

#include<iostream>
#include<fstream>
using namespace std;
int max(int a,int b)
{return a>b?a:b;}
int main()
{
	int i,j,t,tot,kind,vaule,V;
	int c[10000],n[20],f[100010];
	while(cin>>V)
	{
		cin>>kind;
		memset(f,0,sizeof(f));
		tot=0;
		for(i=1;i<=kind;i++)
		{
			cin>>n[i]>>vaule;
			if(n[i]!=0)//转化为2^0的物品
			{
				tot++;
				c[tot]=vaule;
				n[i]--;
			}
			t=2;
			while(n[i]>=t)//转化为t个物品,t=2^1,2^2,2^3...
			{
				n[i]-=t;
				tot++;
				c[tot]=vaule*t;
				t*=2;
			}
			if(n[i]>0)//剩下的编为一组
			{
				tot++;
				c[tot]=vaule*n[i];
			}
		}
		for(i=1;i<=tot;i++)//01背包问题
			for(j=V;j>=c[i];j--)
				f[j]=max(f[j],f[j-c[i]]+c[i]);
				cout<<f[V]<<endl;
	}
	return 0;
}

 

 

抱歉!评论已关闭.