现在的位置: 首页 > 综合 > 正文

钓鱼 poj-1042

2013年03月06日 ⁄ 综合 ⁄ 共 3148字 ⁄ 字号 评论关闭
Gone Fishing
Time Limit: 2000MS
Memory Limit: 32768K
Total Submissions: 25911
Accepted: 7627

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can
finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,...,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted
ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial
5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than
or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.

Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n),
then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.

Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on
one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line
between cases.

Sample Input

2 
1 
10 1 
2 5 
2 
4 
4 
10 15 20 17 
0 3 4 3 
1 2 3 
4 
4 
10 15 50 30 
0 3 4 3 
1 2 3 
0 

Sample Output

45, 5 
Number of fish expected: 31 

240, 0, 0, 0 
Number of fish expected: 480 

115, 10, 50, 35 
Number of fish expected: 724 

思路:总体思想是贪心,先枚举John只在前1.2.3...n个池塘里钓鱼,然后用总时间减去路上的时间,剩下的时间就是在池塘钓鱼的时间,然后利用贪心思想,在总是在期望钓到鱼最多的池塘里钓即可(减去路上的时间之后,John可以任意在各个池塘之间移动,不用再考虑在池塘间转移路上的时间)。 
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int h,n,f[26],d[26],t[25],time[26],temptime[26],tempf[26];
void copy(int *a,int *b,int n)
{
    for(int i=1;i<=n;++i)
        a[i]=b[i];
}
void test()
{
    int fish=0,max_fish=0;
    for(int i=n;i>=1;--i)
    {
        copy(tempf,f,n);
        int k=h*60/5;
        for(int j=1;j<i;++j)
            k-=t[j];
        while(k>0)
        {
            int temp,cur;
            temp=tempf[1],cur=1;
            for(int l=2;l<=i;++l)
                if(temp<tempf[l])
                {
                    temp=tempf[l];
                    cur=l;
                }
            if(temp>0)
            {
                fish+=temp;
                tempf[cur]-=d[cur];
                if(tempf[cur]<0)
                    tempf[cur]=0;
            }
            temptime[cur]++;
            k--;
        }
        if(fish>=max_fish)//注意要等号
        {
            max_fish=fish;
            copy(time,temptime,n);
        }
        memset(temptime,0,sizeof(temptime));
        fish=0;
    }
    for(int i=1;i<=n-1;i++)
        cout<<5*time[i]<<", ";
    cout<<5*time[n]<<endl ;
    printf("Number of fish expected: %d\n\n",max_fish);
}
int main()
{
    //freopen("d:\\test.txt","r",stdin);
    int i=1;
    while(cin>>n && n)
    {
        cin>>h;
        for(i=1;i<=n;++i)
            cin>>f[i];
        for(i=1;i<=n;++i)
            cin>>d[i];
        for(i=1;i<n;++i)
            cin>>t[i];
        test();
        memset(time,0,sizeof(time));
    }
    return 0;
}

抱歉!评论已关闭.