现在的位置: 首页 > 综合 > 正文

POJ 1836 Alignment [未优化]

2013年03月22日 ⁄ 综合 ⁄ 共 2056字 ⁄ 字号 评论关闭
Language:
Alignment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8028   Accepted: 2535

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned
in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new
line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of
the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source

//题意是一排身高,要求每个人都能从左边或者右边看到排头
//分析一下大概就知道是个DP问题...是经典的lis问题(Longest Increasing Subsequence)(具体百度)
//用了两个状态数组分别存放 正序最长递增子序列 和 逆序最长递增子序列 
//数组中的每个元素都是存放的到这一个身高为止的lis值
//最后一次枚举找出最大的lis就行了
//数据比较小,所以用朴素的lis就行
//如果要求时间更短的话可以用二分(具体见百度)
#include<stdio.h>
int max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int n,i,j;
	int lis1[1000];
	int lis2[1000];
	double height[1000];
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%lf",&height[i]);
		lis1[i]=1;
		lis2[i]=1;  //初状态,lis初始值都是本身
	}
	for(i=0;i<n;i++) //正序lis
	{
		for(j=i;j>=0;j--)
		{
			if(height[i]>height[j])
				lis1[i] = max(lis1[i],lis1[j]+1); 
		}
	}
	for(i=n-2;i>=0;i--)//逆序lis
	{
		for(j=n-1;j>i;j--)
		{
			if(height[i]>height[j])
				lis2[i] = max(lis2[i],lis2[j]+1);
		}
	}
	int m=0;
	for(i=0;i<n;i++)
	{
		for(j=i+1;j<n;j++)
		{
			m = max(m,lis1[i]+lis2[j]);
		}
	}
	printf("%d\n",n-m);
	return 0;
}

抱歉!评论已关闭.