现在的位置: 首页 > 综合 > 正文

HDU 1213 How Many Tables 简单并查集

2014年02月06日 ⁄ 综合 ⁄ 共 1877字 ⁄ 字号 评论关闭


How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6073    Accepted Submission(s): 2894


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 


Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 


Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 


Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5
 


Sample Output
2 4
 


Author
Ignatius.L
 


Source
 


Recommend
Eddy
 

查了再并...就是这么easy...

#include <set>
#include <list>
#include <cmath>
#include <ctime>
#include <deque>
#include <queue>
#include <stack>
#include <cctype>
#include <cstdio>
#include <string>
#include <vector>
#include <cassert>
#include <cstdlib>
#include <cstring>
#include <sstream>
#include <iostream>
#include <algorithm>
using namespace std;
int father[1001];
int sum;
int find(int x)
{
	if(x!=father[x])
		father[x] = find(father[x]);
	//回溯,所有节点都变为祖宗节点的子节点...即树的深度=2
	return father[x];
}
void Union(int a,int b)
{
	int x = find(a);
	int y = find(b);
	if(x==y)
		return;
	sum--;
	father[y]=x;
}
int main()
{
//	freopen("in.txt","r",stdin);
	int x;
	cin>>x;
	while(x--)
	{
		memset(father,0,sizeof(father));
		int n,m,i,j;
		cin>>n>>m;
		for(i=1;i<=1001;i++)
			father[i]=i;
		sum=n;
		while(m--)
		{
			int a,b;
			cin>>a>>b;
			Union(a,b);	
		}
		cout<<sum<<endl;
	}
	
    return 0;
}

抱歉!评论已关闭.