现在的位置: 首页 > 综合 > 正文

深搜与一般组合

2013年02月13日 ⁄ 综合 ⁄ 共 2231字 ⁄ 字号 评论关闭

zoj 1089

Lotto


Time Limit: 2 Seconds      Memory Limit: 65536 KB


In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select
a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34],
[1,2,3,5,13,21], ... [3,5,8,13,21,34].

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line
will be the number 
k (6 < k <
13). Then 
k integers, specifying the set S, will follow in ascending order. Input will be
terminated by a value of zero (0) for 
k.

Output Specification

For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space.
The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank
line. Do not put a blank line after the last test case.

Sample Input

7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0

Sample Output

1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7

1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34
题意: 给你一个递增序列长度最小于 13,然后找出其中 6 个数的任意组合,一字典序
输出,即第一个数谁小先输出谁,如果相同则看第二个数……
思路:用深搜枚举出所有情况。。。。要注意输出的格式,最后不能有空行

一般组合
这题就是这种一般组合的模型,所给的数列是各不相同的N个数。。。。
 
输入 n 个数,从中选出 m 个数可构成集合,输出所有这样的集合。 
输入样例 
4 3 
1 2 3 4 
输出样例 
1 2 3 
1 2 4 
1 3 4 
2 3 4 

我的代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int data[15],num[15],n;
void dfs(int a,int tot)//接下来搜索的数组下标 a 和 当前集合已经有的几个数 tot
{
    int i;
    if(tot==6)
    {
        printf("%d",num[0]);
        for(i=1;i<6;i++)
        printf(" %d",num[i]);
        puts("");
        return;
    }
    for(i=a;i<n;i++)
    {
        num[tot]=data[i];
        dfs(i+1,tot+1);
    }
}
int main()
{
    int i,f=0;
    while(scanf("%d",&n)&&n)
    {
        for(i=0;i<n;i++)
        scanf("%d",&data[i]);
        if(f==1)
        puts("");
        f=1;
        dfs(0,0);
    }
    return 0;
}

抱歉!评论已关闭.