现在的位置: 首页 > 综合 > 正文

UVA 10881 Piotr’s Ants

2014年04月05日 ⁄ 综合 ⁄ 共 2393字 ⁄ 字号 评论关闭

点击打开链接

Problem D
Piotr's Ants

Time Limit: 2 seconds

 

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."

 

Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontal pole
L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the
ants starts and which direction it is facing and wants to calculate where the ants will end up
T seconds from now.

Input
The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing 3 integers:
L , T and n (0 <=
n
<= 10000)
. The next n lines give the locations of the
n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by
n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant
falls off the pole before T seconds, print "Fell off" for that ant. Print an empty line after each test case.

 

Sample Input Sample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R

 

 


Problemsetter: Igor Naverniouk
Alternate solutions: Frank Pok Man Chu and Yury Kholondyrev

 

长l厘米的木棍上有n只蚂蚁,蚂蚁要么向左爬,要么向右爬,速度1cm/s。当两只蚂蚁碰面时,同时掉转方向。给出每只蚂蚁的初始朝向和位置,求t秒后每只蚂蚁位置。

蚂蚁相遇掉头后其实就是相穿而过。但是蚂蚁的编号就搞乱了,因此一开始要编号每只蚂蚁。着重理解好蚂蚁开始和结束的位置。。

#include<stdio.h>
#include<algorithm>
using namespace std;
int pos[10007];
struct sa
{
	int cur;
	int p;
	int d;
	bool operator<(const sa& a) const
	{
		return p<a.p;
	}
}ant_before[10007],ant_after[10007];
char name[3][10]={"L","Turning","R"};
int main()
{
	int kase;
	scanf("%d",&kase);
	for(int i=1;i<=kase;i++)
	{
		printf("Case #%d:\n",i);
		int l,t,n,j;
		scanf("%d%d%d",&l,&t,&n);		
		char s;
		for(j=0;j<n;j++)//蚂蚁之前的状态 
		{
			scanf("%d %c",&ant_before[j].p,&s);
			//getchar();
			int d;
			if(s=='R') d=1;
			else d=-1;
			//printf("%d\n",d);
			ant_before[j].d=d;
			ant_before[j].cur=j;
		}
		for(j=0;j<n;j++)//蚂蚁之后的状态 
		{
			ant_after[j].p=ant_before[j].p+ant_before[j].d*t;
			ant_after[j].d=ant_before[j].d;
			ant_after[j].cur=0;
		}
		sort(ant_before,ant_before+n);
		for(j=0;j<n;j++)//计算pos数组 
		pos[ant_before[j].cur]=j;
		sort(ant_after,ant_after+n);
		for(j=0;j<n-1;j++)//修改碰撞中蚂蚁的方向 
		if(ant_after[j].p==ant_after[j+1].p)
		{
			ant_after[j].d=ant_after[j+1].d=0;
		}
		for(j=0;j<n;j++)
		{
			int a=pos[j];
			if(ant_after[a].p<0||ant_after[a].p>l)
			{
				printf("Fell off\n");
			}
			else
			printf("%d %s\n",ant_after[a].p,name[ant_after[a].d+1]);
		}
		printf("\n");
	}
	return 0;
}

 

抱歉!评论已关闭.