现在的位置: 首页 > 综合 > 正文

LA 3263 – That Nice Euler Circuit 欧拉定理

2014年04月05日 ⁄ 综合 ⁄ 共 4228字 ⁄ 字号 评论关闭

点击打开链接

 

3263 - That Nice Euler Circuit

Time limit: 3.000 seconds

Little Joey invented a scrabble machine that he called Euler, after the great mathematician. In his primary school Joey heard about the nice story of how Euler started the study about graphs. The problem in that story was - let me remind you - to draw a
graph on a paper without lifting your pen, and finally return to the original position. Euler proved that you could do this if and only if the (planar) graph you created has the following two properties: (1) The graph is connected; and (2) Every vertex in
the graph has even degree.

Joey's Euler machine works exactly like this. The device consists of a pencil touching the paper, and a control center issuing a sequence of instructions. The paper can be viewed as the infinite two-dimensional plane; that means you do not need to worry about
if the pencil will ever go off the boundary.

In the beginning, the Euler machine will issue an instruction of the form
(X0, Y0)
which moves the pencil to some starting position
(X0, Y0). Each subsequent instruction is also of the form
(X', Y'), which means to move the pencil from the previous position to the new position
(X', Y'), thus draw a line segment on the paper. You can be sure that the new position is different from the previous position for each instruction. At last, the Euler machine will always issue an instruction that
move the pencil back to the starting position (X0,
Y
0)
. In addition, the Euler machine will definitely not draw any lines that overlay other lines already drawn. However, the lines may intersect.

After all the instructions are issued, there will be a nice picture on Joey's paper. You see, since the pencil is never lifted from the paper, the picture can be viewed as an Euler circuit.

Your job is to count how many pieces (connected areas) are created on the paper by those lines drawn by Euler.

Input 

There are no more than 25 test cases. Ease case starts with a line containing an integer
N$ \ge$4, which is the number of instructions in the test case. The following
N pairs of integers give the instructions and appear on a single line separated by single spaces. The first pair is the first instruction that gives the coordinates of the starting position. You may assume there are no more
than 300 instructions in each test case, and all the integer coordinates are in the range (-300, 300). The input is terminated when
N is 0.

Output 

For each test case there will be one output line in the format

Case x: There are w pieces.,

where x is the serial number starting from 1.

Note: The figures below illustrate the two sample input cases.

\epsfbox{p3263.eps}

Sample Input 

5
0 0 0 1 1 1 1 0 0 0 
7 
1 1 1 5 2 1 2 5 5 1 3 5 1 1 
0

Sample Output 

Case 1: There are 2 pieces. 
Case 2: There are 5 pieces.

 

题意:平面上有一个N端点的一笔画,第N个端点总是和第一个端点重合,因此图案是一条闭合曲线。组成一笔画的线段可以相交,但是不会部分重叠,求这些线段将平面分成多少部分。

欧拉定理:设平面的顶点数,边数和面数分别是V,E和F,则V+F-E=2.则只要求出顶点数V和边数E,就可以求出F=E+2-V。改平面的结点由两部分组成,即原来的结点和新增的结点。由于可能出现三点共线,需要删除重复的点。

#include<stdio.h>
#include<algorithm>
#include<math.h>
#define maxn 330
using namespace std;
struct Point
{
    double x,y;
    Point(double x=0,double y=0):x(x),y(y){}//构造函数
};
typedef Point Vector;
Point P[maxn],V[maxn*maxn];

//向量+向量=向量,点+向量=点
Point operator+(Point A,Point B)
{
    return Point(A.x+B.x,A.y+B.y);
}

//点-点=向量
Point operator-(Point A,Point B)
{
    return Point(A.x-B.x,A.y-B.y);
}


//向量*数=向量
Point operator*(Point A,double p)
{
    return Point(A.x*p,A.y*p);
}


//向量/数=向量
Point operator/(Point A,double p)
{
    return Point(A.x/p,A.y/p);
}
double eps=1e-10;
double Cross(Point A,Point B)
{
   return A.x*B.y-A.y*B.x;
}
//如果等于0,返回0,小于0返回-1,大于0,返回1
int dcmp(double x)
{
    if(fabs(x)<eps)return 0;else return x<0?-1:1;
}

//判断是否相等
bool operator==(const Point& a,const Point &b)
{
    return dcmp(a.x-b.x)==0&&dcmp(a.y-b.y)==0;
}
//判断线段相交(不含端点)
bool SegmentProperIntersection(Point a1,Point a2,Point b1,Point b2)
{
    double c1=Cross(a2-a1,b1-a1),c2=Cross(a2-a1,b2-a1),
    c3=Cross(b2-b1,a1-b1),c4=Cross(b2-b1,a2-b1);
    return dcmp(c1)*dcmp(c2)<0&&dcmp(c3)*dcmp(c4)<0;
}


//直线交点公式
Point  GetLineIntersection(Point P,Point V,Point Q,Point W)
{
    Point u=P-Q;
    double t=Cross(W,u)/Cross(V,W);
    return P+V*t;
}
double Dot(Point A,Point B)
{
    return A.x*B.x+A.y*B.y;
}


//判断一个点P是否在一条线段a1a2上
bool OnSegment(Point p,Point a1,Point a2)
{
    return dcmp(Cross(a1-p,a2-p))==0&&dcmp(Dot(a1-p,a2-p));
}
bool cmp(Point a,Point b)
{
    if(a.x-b.x>eps)
    return true;
    else if(fabs(a.x-b.x)<eps&&a.y-b.y>eps)
    return true;
    return false;
}
int main()
{
    int n,cas=0;
    while(scanf("%d",&n),n)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&P[i].x,&P[i].y);
            V[i]=P[i];
        }
        n--;
        int c=n,e=n;
        for(int i=0;i<n;i++)
        for(int j=i+1;j<n;j++)
        if(SegmentProperIntersection(P[i],P[i+1],P[j],P[j+1]))
        {
            V[c++]=GetLineIntersection(P[i],P[i+1]-P[i],P[j],P[j+1]-P[j]);
        }
        sort(V,V+c,cmp);
        c=unique(V,V+c)-V;
        for(int i=0;i<c;i++)
        for(int j=0;j<n;j++)
        if(OnSegment(V[i],P[j],P[j+1]))e++;
        printf("Case %d: There are %d pieces.\n",++cas,e+2-c);
    }
    return 0;
}

 

 

抱歉!评论已关闭.