现在的位置: 首页 > 综合 > 正文

搜索(dfs)

2014年05月30日 ⁄ 综合 ⁄ 共 2338字 ⁄ 字号 评论关闭
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately
to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 

 

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively.
The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 

 

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 
 

Sample Input

4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output

NO YES
 对于dfs和bfs的应用,主要表现在对图的搜索上;
对于本题,和上个bfs相似:方向,起点,终点;
但是这个题有些剪枝:
1.奇偶剪枝:
记住这个定理:
所有路径-最短路径的差必定为偶数;
2.步数与时间的关系;
若最短步数>时间肯定不符合;
#include<stdio.h>
#include<math.h>
#include<string.h>
int state[10][10],time,a,b,rx,ry,ax,ay;
char map[10][10];
int num[4][2]={{0,1},{0,-1},{1,0},{-1,0}},flag;
void DFS(int x,int y,int step)
{
    int i,kx,ky;
    if(x==ax&&y==ay)
    {
        if(step==time)
        flag=1;
        return;
    }
    if(step==time)return;
    if(map[x][y]=='X')return;
    if(flag)return;
    for(i=0;i<4;i++)
    {
        kx=x+num[i][0];
        ky=y+num[i][1];
        if(kx<0||kx>=a||ky<0||ky>=b)continue;
        if(state[kx][ky]==0)
        {
            state[kx][ky]=1;
            DFS(kx,ky,step+1);
            state[kx][ky]=0;
            if(flag)return;
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d%d%*c",&a,&b,&time)!=EOF)
    {
    	if(a==0&&b==0&&time==0)break;
        memset(state,0,sizeof(state));
        for(i=0;i<a;i++)
        {
            
            for(j=0;j<b;j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j]=='S'){rx=i;ry=j;}
                if(map[i][j]=='D'){ax=i;ay=j;}
            }
            getchar();
        }
        if(fabs(rx-ax)+fabs(ry-ay)>time||( rx + ry + ax + ay +time )%2==1){printf("NO\n");continue;}
        flag=0;
        state[rx][ry]=1;
        DFS(rx,ry,0);
        state[rx][ry]=0;
        if(flag)
            printf("YES\n");
        else printf("NO\n");
    }
    return 0;
    } 

抱歉!评论已关闭.