现在的位置: 首页 > 综合 > 正文

UVa 10161 Ant on a Chessboard 计算题

2014年06月06日 ⁄ 综合 ⁄ 共 1739字 ⁄ 字号 评论关闭
文章目录

10161 - Ant on a Chessboard

 

Background

  One day, an ant called Alice came to an M*M chessboard. She wanted to go around all the grids. So she began to walk along the chessboard according to this way: (you can assume that her speed is one grid per second)

  At the first second, Alice was standing at (1,1). Firstly she went up for a grid, then a grid to the right, a grid downward. After that, she went a grid to the right, then two grids upward, and then two grids to the left…in a word, the path was like a
snake.

  For example, her first 25 seconds went like this:

  ( the numbers in the grids stands for the time when she went into the grids)

 

25

24

23

22

21

10

11

12

13

20

9

8

7

14

19

2

3

6

15

18

1

4

5

16

17

5

4

3

2

1

 

1          2          3           4           5

At the 8th second , she was at (2,3), and at 20th second, she was at (5,4).

Your task is to decide where she was at a given time.

(you can assume that M is large enough)

 

 

Input

  Input file will contain several lines, and each line contains a number N(1<=N<=2*10^9), which stands for the time. The file will be ended with a line that contains a number 0.

 

 

Output

  For each input situation you should print a line with two numbers (x, y), the column and the row number, there must be only a space between them.

 

 

Sample Input

8

20

25

0

 

 

Sample Output

2 3

5 4

1 5

题解

这道题要说难点应该是在找规律那里。首先判断平方数,然后是其他数。接着判断奇偶性,用来判断那一列的增减性。其他的就没什么了,具体的计算过程看代码。

代码示例

/****
	*@PoloShen
	*Title:UVa 10161
	*/
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

void solve(int n){
    int k = floor(sqrt(double(n)));
    if (k * k == n){
        if (k&1) printf("%d %d\n", 1, k);
        else printf("%d %d\n", k, 1);
    } else {
        int t = n - k * k;
        int m = t % (k + 1);
        if (k & 1){
            if (t <= k + 1) printf("%d %d\n", t, k + 1);
            else printf("%d %d\n", k + 1, k + 1 - m);
        } else {
            if (t <= k + 1) printf("%d %d\n", k + 1, t);
            else printf("%d %d\n", k + 1 - m, k + 1);
        }
    }
}

int main(){
    int n = 0;
    while (cin >> n && n) solve(n);
    return 0;
}

抱歉!评论已关闭.