现在的位置: 首页 > 综合 > 正文

USACO_Broken Necklace解题报告

2014年06月07日 ⁄ 综合 ⁄ 共 2618字 ⁄ 字号 评论关闭


Broken Necklace

You have a necklace of N red, white, or blue beads (3<=N<=350) some of which are red, others blue, and others white, arranged at random. Here are two examples for n=29:

1 2 1 2 r b b r b r r b r b b b r r b r r r w r b r w w b b r r b b b b b b r b r r b r b r r r b r r r r r r b r b r r r w Figure A Figure B r red bead b blue bead w white bead

The beads considered first and second in the text that follows have been marked in the picture.

The configuration in Figure A may be represented as a string of b's and r's, where b represents a blue bead and r represents a red one, as follows: brbrrrbbbrrrrrbrrbbrbbbbrrrrb .

Suppose you are to break the necklace at some point, lay it out straight, and then collect beads of the same color from one end until you reach a bead of a different color, and do the same for the other end (which might not be of the same color as the beads
collected before this).

Determine the point where the necklace should be broken so that the most number of beads can be collected.

Example

For example, for the necklace in Figure A, 8 beads can be collected, with the breaking point either between bead 9 and bead 10 or else between bead 24 and bead 25.

In some necklaces, white beads had been included as shown in Figure B above. When collecting beads, a white bead that is encountered may be treated as either red or blue and then painted with the desired color. The string that
represents this configuration will include the three symbols r, b and w.

Write a program to determine the largest number of beads that can be collected from a supplied necklace.

PROGRAM NAME: beads

INPUT FORMAT

Line 1: N, the number of beads
Line 2: a string of N characters, each of which is r, b, or w

SAMPLE INPUT (file beads.in)

29 wwwbbrwrbrbrrbrbrwrwwrbwrwrrb

OUTPUT FORMAT

A single line containing the maximum of number of beads that can be collected from the supplied necklace.

SAMPLE OUTPUT (file beads.out)

11

OUTPUT EXPLANATION

Consider two copies of the beads (kind of like being able to runaround the ends). The string of 11 is marked.

wwwbbrwrbrbrrbrbrwrwwrbwrwrrb wwwbbrwrbrbrrbrbrwrwwrbwrwrrb ****** ***** wwwwwb bbbbb <-- assignments 5 x w 6 x b <-- 11 total
解题建议:
初学者只要按照题目要求,一步一步写好判断条件,进行枚举就行,最好不要尝试高级算法,其实很简单。
以下是代码:
 
#include<stdio.h>
#include<string.h>
char s[400];
int n;
int search(int x)
{
    char a,b;
    int count=0,flag=0,sum=0;
    int i=x+1;
    while(1)
    {
        if(i>=n)
        {
            i=i%n;
        }
        if(s[i]!='w'&&flag==0)
        {
            a=s[i];
            flag++;
            count++;
        }
        else if(s[i]=='w'||s[i]==a)
            count++;
        else if(s[i]!='w'&&s[i]!=a)
            break;
        i++;
        if(i==x+1)
            break;
        //printf("%d\n",i);
        //printf("%d\n",flag);
       // printf("%d\n\n",count);
    }
    sum+=count;
    count=0,flag=0;
    int j=x;
    while(j!=i-1)
    {
        if(j<0)
        {
            j=n-1;
        }
        if(s[j]!='w'&&flag==0)
        {
            a=s[j];
            flag++;
            count++;
        }
        else if(s[j]=='w'||s[j]==a)
            count++;
        else if(s[j]!='w'&&s[j]!=a)
            break;
        --j;
        if(j==x)
            break;
        //printf("%d\n",j);
        //printf("%d\n",flag);
      //  printf("%d\n\n",count);
    }
    sum+=count;
    return sum;
}
int main()
{
    int i,k=0,m=0;
    freopen("beads.in","r",stdin);
    freopen("beads.out","w",stdout);
    scanf("%d ",&n);
    gets(s);
    for(i=0;i<n;i++)
    {
    m=search(i);
    if(m>k)
    k=m;
    }
    printf("%d\n",k);
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.