现在的位置: 首页 > 综合 > 正文

ACM学习-POJ-1004-Financial Management

2014年06月11日 ⁄ 综合 ⁄ 共 1454字 ⁄ 字号 评论关闭

菜鸟学习ACM,纪录自己成长过程中的点滴。

学习的路上,与君共勉。

ACM学习-POJ-1003-Financial Management

Financial Management
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 109412   Accepted: 51958

Description

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's
been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters
in the output.

Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75

Sample Output

$1581.42

Source

问题要求:
 求12个数的平均数。
问题分析:
.....看到这题目,顿时吓尿了。   我做题目都是看AC率下手的。  从50%开始逐步练习。  不过这道AC率48%的题目,确实水的可以了。  估计大牛们都不屑做这个吧。   好吧,这道也没什么特别需要注意的。 就是类型转换的时候注意下就好了。  直接上代码吧。
#include <stdio.h>

int main()
{
    int n = 0;
    double sum_ = 0.0;
    double each_month;
    
    while (~scanf("%lf", &each_month) && n < 12)
    {
        sum_ += each_month;
        n++;
        if (n==12)
        {
            printf("$%.2lf\n", sum_/(double)n);
            break;
        }
    }
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.