现在的位置: 首页 > 综合 > 正文

ACM学习-POJ-1003-Hangover

2014年06月11日 ⁄ 综合 ⁄ 共 1582字 ⁄ 字号 评论关闭

菜鸟学习ACM,纪录自己成长过程中的点滴。

学习的路上,与君共勉。

ACM学习-POJ-1003-Hangover

Hangover
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 92150   Accepted: 44638

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the
bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1)
card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will
contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

Source

问题要求:已知c=1/2+1/3+1/4+....1/(n+1).现给出一个值m,求n的值使得c刚好超过m。

问题分析:问题很简单,就是遍历,直到找到满足条件的那个n。 但是要注意运算的时候进行类型转换。(最早做的时候卡在这里了,一时粗心没注意)


下面给出AC代码

#include <stdio.h>

int main()
{
    double sum_;
    double result_;
    int n;
    
    while ((~scanf("%lf", &sum_)) && sum_ != 0.00   )
    {
        result_ = 0.00;
        for (n=2;result_ <= sum_ ; n++)
        {
            result_ += 1.00/(double)n;//注意类型的转换
        }
        printf("%d card(s)\n", n-2);
    }
    return 0;
}

抱歉!评论已关闭.