现在的位置: 首页 > 综合 > 正文

HDU 1686 kmp模式串计数

2014年08月29日 ⁄ 综合 ⁄ 共 2507字 ⁄ 字号 评论关闭

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3809    Accepted Submission(s): 1504

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
1 3 0

题意:给定a串,b串,统计a串在b串中出现多少次。

解题思路:kmp,根据next数组统计,纠结了好久。

代码:

#include <iostream>
#include <stdio.h>
#include <string>
using namespace std;

int next[10005], num;
void get_next(char *str)
{
      int len=strlen(str);
      int i,j=0,k=-1;
      next[0]=-1;
      while(j<len)
      {
	     if(k==-1||str[j]==str[k])next[++j]=++k;
	     else k=next[k];
      }
}
int kmp(char *x,char *y)
{
      int len1=strlen(x);
      int len2=strlen(y);
      int i=0,j=0,ans=0;
      get_next(x);
      while(i<len2)
      {
	     while(j!=-1&&y[i]!=x[j])j=next[j];
	     i++;j++;
	     if(j>=len1)
	     {
		    ans++;
		    j=next[j];
	     }
      }
      return ans;
}
char a[10005], b[1000050];
int main()
{
      //freopen("data.in","r",stdin);
      //freopen("data.out","w",stdout);
      int T;
      scanf("%d",&T);
      while(T--)
      {
	     scanf("%s%s",a,b);
	     printf("%d\n",kmp(a,b));
      }
      return 0;
}


抱歉!评论已关闭.