现在的位置: 首页 > 综合 > 正文

HDU 1686 Oulipo kmp入门

2014年09月03日 ⁄ 综合 ⁄ 共 2416字 ⁄ 字号 评论关闭

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4004    Accepted Submission(s): 1580


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that
counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All
the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 


Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

 


Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 


Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 


Sample Output
1 3 0
 


Source

//109MS	1252K
#include<stdio.h>
#include<string.h>
char text[1000007],pattern[10007];
int next[10007],n,m;
void pre()
{
    next[0]=-1;
    int j=-1;
    for(int i=1;i<m;i++)
    {
        while(j>=0&&pattern[j+1]!=pattern[i])j=next[j];
        if(pattern[j+1]==pattern[i])j++;
        next[i]=j;
    }
}
int kmp()
{
    int ans=0,j=-1;
    for(int i=0;i<n;i++)
    {
        while(j>=0&&pattern[j+1]!=text[i])j=next[j];
        if(pattern[j+1]==text[i])j++;
        if(j==m-1)ans++;
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%s",pattern,text);
        m=strlen(pattern);
        n=strlen(text);
        pre();
        printf("%d\n",kmp());
    }
    return 0;
}

抱歉!评论已关闭.