现在的位置: 首页 > 综合 > 正文

hdu2115 I Love This Game(排名)

2014年09月05日 ⁄ 综合 ⁄ 共 1892字 ⁄ 字号 评论关闭

I Love This Game

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5248    Accepted Submission(s): 1811


Problem Description
Do you like playing basketball ? If you are , you may know the NBA Skills Challenge . It is the content of the basketball skills . It include several parts , such as passing , shooting , and so on. After completion of the content , the player who takes the
shortest time will be the winner . Now give you their names and the time of finishing the competition , your task is to give out the rank of them ; please output their name and the rank, if they have the same time , the rank of them will be the same ,but you
should output their names in lexicographic order.You may assume the names of the players are unique.

Is it a very simple problem for you? Please accept it in ten minutes.

 


Input
This problem contains multiple test cases! Ease test case contain a n(1<=n<=10) shows the number of players,then n lines will be given. Each line will contain the name of player and the time(mm:ss) of their finish.The end of the input will be indicated by an
integer value of zero.
 


Output
The output format is shown as sample below.
Please output the rank of all players, the output format is shown as sample below;
Output a blank line between two cases.
 


Sample Input
10 Iverson 17:19 Bryant 07:03 Nash 09:33 Wade 07:03 Davies 11:13 Carter 14:28 Jordan 29:34 James 20:48 Parker 24:49 Kidd 26:46 0
 


Sample Output
Case #1 Bryant 1 Wade 1 Nash 3 Davies 4 Carter 5 Iverson 6 James 7 Parker 8 Kidd 9 Jordan 10
 

注意格式就行了

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct ren
{
    char name[20];
    int mm,ss;
} s[15];
bool cmp(ren a,ren b)
{
    if(a.mm==b.mm&&a.ss==b.ss) return strcmp(a.name,b.name)<0;
    if(a.mm==b.mm) return a.ss<b.ss;
    return a.mm<b.mm;
}
int main()
{
    int n,cas=1,i,mmm,sss,rate,o=0;;
    while(scanf("%d",&n),n)
    {
        for(i=0; i<n; i++)
            scanf("%s%d:%d",&s[i].name,&s[i].mm,&s[i].ss);
        if(o) printf("\n");
        o++;
        sort(s,s+n,cmp);
        printf("Case #%d\n",cas++);
        mmm=sss=rate=0;
        for(i=0; i<n; i++)
        {
            bool ok=0;
            if(mmm!=s[i].mm||sss!=s[i].ss)
            {
                rate++;
                ok=1;
            }
            printf("%s %d\n",s[i].name,rate);
            mmm=s[i].mm;
            sss=s[i].ss;
            if(!ok) rate++;
        }
    }
    return 0;
}

抱歉!评论已关闭.