现在的位置: 首页 > 综合 > 正文

HDU 3033 –I love Sneakers(Mark-第一次写博客)

2014年09月05日 ⁄ 综合 ⁄ 共 2261字 ⁄ 字号 评论关闭

分组背包 每组至少选一个

(只需注意 1:组内进行01背包   2:状态转移是从有效状态得来 此处有效状态指该组已选)

PS:若每组至多选一个 则先状态后组内物品

Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.


There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he
won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a
product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 
Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.
 
Sample Input
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66
 
Sample Output
255
源码如下

#include<cstdio>
#include<cmath>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 10010;

int N,M,K;
int snkc[15][105], snkw[15][105], bnum[15];
int f[15][maxn];	
		
void sol(){
	for(int i=1;i<=K;++i){
		if( ! bnum[i] ) {
			puts("Impossible"); return ;
		}
			for(int k=0;k<bnum[i];++k)
			for(int j=M;j>-1;--j)
			{
				if(j < snkc[i][k]) break;
				//下面两个位置不能交换  数据在下面 
				if(f[i][j-snkc[i][k]] != -1) 
					f[i][j] = max(f[i][j],f[i][j-snkc[i][k]] + snkw[i][k]);
				if(f[i-1][j-snkc[i][k]] != -1) 
					f[i][j] = max(f[i][j],f[i-1][j-snkc[i][k]]+snkw[i][k]);	
			}						
	}
	int ans = -1;
	for(int i=0;i<=M;++i)ans = max(ans,f[K][i]);
	if(ans == -1)puts("Impossible");
	else printf("%d\n",ans);
	return ;
}			
				
int main(){
	int a, b, c;
	while(~scanf("%d%d%d",&N,&M,&K)){
		memset(bnum,0,sizeof(bnum));
		memset(f,-1,sizeof(f));
		memset(f[0],0,maxn*sizeof(int));
		for(int i=0;i<N;++i){
			scanf("%d%d%d",&a,&b,&c);
			snkc[a][bnum[a]] = b;
			snkw[a][bnum[a]++] = c;
		}
		sol();
	}
	return 0;
}
/*
3 5 3
1 0 5
2 0 1
3 0 2
*/

抱歉!评论已关闭.