现在的位置: 首页 > 综合 > 正文

优先队列2

2014年09月05日 ⁄ 综合 ⁄ 共 2102字 ⁄ 字号 评论关闭
D - 优先队列入门2

Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell
me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 
 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position
of the i-th stone and how far Sempr can throw it. 
 

Output

Just output one line for one test case, as described in the Description. 
 

Sample Input

2 2 1 5 2 4 2 1 5 6 6
 

Sample Output

11 12
 模板题,只是在进行出列的时候需要判断奇偶,同时入列,这时的优先级别改变,需要进行坐标的运算。
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
struct node{
	int val,cla;
	friend bool operator <(node a,node b){
		if(a.cla == b.cla)return a.val >b.val;
		return a.cla >b.cla;
	}
}t;
int main(){
	int n,m;
	scanf("%d",&n);
	while(n--){
		priority_queue<node>Q;
		int s = 0;
		scanf("%d",&m);
		int a,b;
		while(m--){
			scanf("%d%d",&a,&b);
			t.cla = a;
			t.val = b;
			Q.push(t); 
		}
		int l=1;
		while(!Q.empty()){
			t = Q.top();
			if(l&1){
			t.cla = t.cla+t.val;
			s = t.cla;
		    Q.pop();
		    Q.push(t);
			}
			else Q.pop();
			l++;
		}
		printf("%d\n",s);
	}
} 
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
struct node{
	int val,cla;
	friend bool operator <(node a,node b){
		if(a.cla == b.cla)return a.val >b.val;
		return a.cla >b.cla;
	}
}t;
int main(){
	int n,m;
	scanf("%d",&n);
	while(n--){
		priority_queue<node>Q;
		int s = 0;
		scanf("%d",&m);
		int a,b;
		while(m--){
			scanf("%d%d",&a,&b);
			t.cla = a;
			t.val = b;
			Q.push(t); 
		}
		int l=1;
		while(!Q.empty()){
			t = Q.top();
			if(l&1){
			t.cla = t.cla+t.val;
			s = t.cla;
		    Q.pop();
		    Q.push(t);
			}
			else Q.pop();
			l++;
		}
		printf("%d\n",s);
	}
} 

抱歉!评论已关闭.