现在的位置: 首页 > 综合 > 正文

HDU1217:Arbitrage(SPFA)

2014年09月05日 ⁄ 综合 ⁄ 共 2547字 ⁄ 字号 评论关闭
Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys
10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

 

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within
a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name
cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 
 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 
 

Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 

Sample Output
Case 1: Yes Case 2: No
 
题意:在每种钱币间进行各种交换,最后换回自己如果能赚,那么就Yes,否则No
思路:以汇率为边,因为是实数,所以有可能为负,用SPFA处理,再次体会到map的强大
 
#include <stdio.h>
#include <iostream>
#include <cstring>
#include <map>
#include <queue>
#include <algorithm>
using namespace std;

const int L = 35;
const double inf = 1000000;
map<string,int> mat;
int n,m;
char str[105],s1[105],s2[105];
double trip[35][35],dis[35];

int SPFA(int src)
{
    queue<int> Q;
    int vis[35],i;
    int num[35];
    for(i = 1; i<=n; i++)
        vis[i] = dis[i] = num[i] = 0;
    while(!Q.empty())
        Q.pop();
    dis[src] = 1.0;
    vis[src] = 1;
    Q.push(src);
    while(!Q.empty())
    {
        int now = Q.front();
        Q.pop();
        vis[now] = 0;
        for(i = 1; i<=n; i++)
        {
            if(dis[now]*trip[now][i]>dis[i])
            {
                dis[i] = dis[now]*trip[now][i];
                if(dis[src]>1.0)
                    return 1;
                if(!vis[i])
                {
                    vis[i] = 1;
                    Q.push(i);
                }
            }
        }
    }
    return 0;
}

int main()
{
    int i,j,cas = 1;
    double w;
    while(~scanf("%d",&n),n)
    {
        mat.clear();
        for(i = 1; i<=n; i++)
            for(j = 1; j<=n; j++)
                trip[i][j] = (i==j)?1.0:0;
        for(i = 1; i<=n; i++)
        {
            scanf("%s",str);
            mat[str] = i;
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%s%lf%s",s1,&w,s2);
            trip[mat[s1]][mat[s2]] = w;
        }
        int flag = 0;
        for(i = 1; i<=n; i++)
        {
            if(SPFA(i))
            {
                flag = 1;
                break;
            }
        }
        printf("Case %d: %s\n",cas++,flag?"Yes":"No");
    }

    return 0;
}

抱歉!评论已关闭.