现在的位置: 首页 > 综合 > 正文

hdu1013!水题

2014年09月24日 ⁄ 综合 ⁄ 共 1213字 ⁄ 字号 评论关闭
/*Digital Roots
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48333    Accepted Submission(s): 15024

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is 
the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as
 necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24.
 Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. 
 Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output
For each integer in the input, output its digital root on a separate line of the output.
 
Sample Input
24
39
0
 
Sample Output
6
3
 
Source
Greater New York 2000 
*/
#include<stdio.h>
#include<string.h>
int main()
{
    int n , i, j;
    char s[1000];
    while(scanf("%s", s) != EOF )
    {
		if(s[0] == '0')
		break;
		n = 0;
		j = strlen(s);
		for(i = 0; i < j; i++)
		n += s[i] - 48;
    	while(n > 9)
    	{
			j = n;
			i = 0;
			while(j)
			{
					i += j % 10;
				j /= 10;
			}
			n = i;
		}
		printf("%d\n", n);
	}
	return  0;
}

 

唯一需要注意的一点:可以输入大数!!

【上篇】
【下篇】

抱歉!评论已关闭.