现在的位置: 首页 > 综合 > 正文

POJ 1163 The Triangle 数字三角形 经典动态规划

2014年09月30日 ⁄ 综合 ⁄ 共 1912字 ⁄ 字号 评论关闭
The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 36915   Accepted: 22114

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

题解

dp[i][j]表示,走到(i, j)时的最大值
转移方程
dp[i][j] = a[i][j] + max(dp[i - 1][j], dp[i - 1][j - 1])

代码示例

/******************************************************************************
*       COPYRIGHT NOTICE
*       Copyright (c) 2014 All rights reserved
*       ----Stay Hungry Stay Foolish----
*
* @author		:Shen
* @name         :[NWPU][2014][TRN][6] B
* @file         :G:\My Source Code\【ACM】训练\[NWPU][2014][TRN][6][0716]简单线性dp\B.cpp
* @date         :2014/07/16 11:46
* @algorithm    :DP
******************************************************************************/

#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <algorithm>
using namespace std;
template<class T>inline bool updateMin(T& a, T b){ return a > b ? a = b, 1 : 0; }
template<class T>inline bool updateMax(T& a, T b){ return a < b ? a = b, 1 : 0; }

typedef long long int64;

const int MaxN = 105;
int n, a[MaxN][MaxN], dp[MaxN][MaxN];

//  dp[i][j]表示,走到(i, j)时的最大值
//  转移方程
//  dp[i][j] = a[i][j] + max(dp[i - 1][j], dp[i - 1][j - 1])

void solve()
{
	for (int i = 0; i < n; i++)
		for (int j = 0; j <= i; j++)
			scanf("%d", &a[i][j]);
	for (int i = 0; i < n; i++)
		for (int j = 0; j <= i; j++)
		{
			int t1 = 0, t2 = 0;
			if (i - 1 >= 0) t1 = dp[i - 1][j];
			if (i - 1 >= 0 && j - 1 >= 0) t2 = dp[i - 1][j - 1];
			dp[i][j] = max(t1, t2) + a[i][j];
		}
	int ans = 0;
	for (int j = 0; j < n; j++)
		updateMax(ans, dp[n - 1][j]);
	printf("%d\n", ans);
}

int main()
{
	while (~scanf("%d", &n)) solve();
	return 0;
}

抱歉!评论已关闭.