现在的位置: 首页 > 综合 > 正文

poj2379

2014年10月06日 ⁄ 综合 ⁄ 共 1625字 ⁄ 字号 评论关闭
Sum of Consecutive Prime Numbers

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has
three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted
in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

Source

判断所给的数是否可以表示为连续的素数之和。先找出10000内的所有素数,然后用一重循环寻找可能的组合即可。
代码如下:
#include<stdio.h>

int prime[10001];//存储素数的数组

void find_prime(void) {
    int number = 0;//素数的个数
    prime[number++] = 2;
    for (int i = 3; i <= 10000; i++) {
        int flag = 0;
        for (int j = 2; j * j <= i; j++) {
            if (!(i % j)) {//如果找到一个因子,这个数就不是素数,标记一下,中断循环
                flag = 1;
                break;
            }
        }
        if (!flag)//如果没有找到因子,这个数就是素数
            prime[number++] = i;
    }
}

int main(void) {
    int n;
    find_prime();
    while (scanf("%d", &n), n) {
        int count = 0;
        for (int i = 0; i <= n; i++) {
            if (prime[i] > n)//如果该素数已经大于n,中断循环
                break;
            int sum = 0;//sum表示连续素数之和
            for (int j = i; j <= n; j++) {
                sum += prime[j];
                if (sum == n)//如果sum=n,找到了一个可能的组合
                    count++;
                if (sum > n)//如果sum>n,中断循环
                    break;
            }
        }
        printf("%d\n", count);//输出结果
    }
    return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.