现在的位置: 首页 > 综合 > 正文

poj1284

2014年10月06日 ⁄ 综合 ⁄ 共 842字 ⁄ 字号 评论关闭
Primitive Roots

Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (xi mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive
root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.

Output

For each p, print a single number that gives the number of primitive roots in a single line.

Sample Input

23
31
79

Sample Output

10
8
24

Source


求原根的个数。当p有原根时,它有φ(φ(p))个原根。此题中p为奇素数,所以φ(p)=p-1,φ(φ(p))=φ(p-1),问题转化为求欧拉函数。
代码如下:
#include<stdio.h>

int euler_phi(int p) {
    int phi = p;
    for (int i = 2; i * i <= p; i++) {
        if (!(p % i)) {
            phi = phi - phi / i;
            while (!(p % i))
                p /= i;
        }
    }
    if (p > 1)
        phi = phi - phi / p;
    return phi;
}

int main(void) {
    int p;
    while (scanf("%d", &p) != EOF) {
        printf("%d\n", euler_phi(p - 1));
    }
    return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.