现在的位置: 首页 > 综合 > 正文

POJ2080 Calendar 模拟

2014年10月11日 ⁄ 综合 ⁄ 共 1816字 ⁄ 字号 评论关闭

只需知道2000年1月1日是星期六,后面便是直接模拟

 

 

Calendar
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 9354   Accepted: 3522

Description

A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.

According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap
years, but 1600, 2000, and 2400 are leap years.
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

Input

The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.

You may assume that the resulting date won’t be after the year 9999.

Output

For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

Sample Input

1730
1740
1750
1751
-1

Sample Output

2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

int year[]={365,366};
int month[][12]={{31,28,31,30,31,30,31,31,30,31,30,31},{31,29,31,30,31,30,31,31,30,31,30,31}};
char s[][20]={"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
int isleap,n;
const int begin=2000;

int main()
{
    while(~scanf("%d",&n) && n!=-1)
    {
        int y,m,d;
        d=n%7;
        n++;
        isleap=1;
        for(y=begin;n>year[isleap];)
        {
            n-=year[isleap];
            y++;
            isleap=(y%400==0 || y%4==0 && y%100!=0)?1:0;
        }
        for(m=0;n>month[isleap][m];m++)
            n-=month[isleap][m];
        m++;
       cout<<y<<"-"<<(m<10?"0":"")<<m<<"-"<<(n<10?"0":"")<<n<<" "<<s[d]<<endl;
    }
    return 0;
}

抱歉!评论已关闭.