现在的位置: 首页 > 综合 > 正文

POJ 2385 Apple Catching

2014年10月14日 ⁄ 综合 ⁄ 共 2031字 ⁄ 字号 评论关闭
Apple Catching
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6639   Accepted: 3229

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must
wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under
only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts
at tree 1.

Input

* Line 1: Two space separated integers: T and W

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS:

解题思路:压缩相同步长下取苹果多的,用dp[i] 记录在 i 步下最多的苹果数目

#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <cstring>
using namespace std;

int dp[40],n,t;

struct node{
    int step,value;
    node(int step0=0,int value0=0){
        step=step0;value=value0;
    }
};

void computing(){
    memset(dp,0,sizeof(dp));
    int x;
    node s,d;
    queue <node> q;
    q.push(s);
    for(int i=0;i<t;i++){
        scanf("%d",&x);
        for(int j=0;j<=n;j++) q.push(node(j,dp[j]));
        int qsize=q.size();
        for(int j=0;j<qsize;j++){
            s=q.front();
            q.pop();
            if(s.step%2==x-1) dp[s.step]=max(dp[s.step],s.value+1);
            else dp[s.step+1]=max(dp[s.step+1],s.value+1);
        }
        /*for(int j=0;j<=n;j++){
            cout<<j<<" "<<dp[j]<<endl;
        }
        cout<<"----------------"<<endl;*/
    }
    int ans=0;
    for(int j=0;j<=n;j++){
        ans=max(ans,dp[j]);
    }
    cout<<ans<<endl;
}

int main(){
    while(scanf("%d%d",&t,&n)!=EOF){
        computing();
    }
    return 0;
}



抱歉!评论已关闭.