现在的位置: 首页 > 综合 > 正文

pku 3370 Halloween treats(鸽巢原理)

2014年10月22日 ⁄ 综合 ⁄ 共 1976字 ⁄ 字号 评论关闭
Halloween treats
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5794   Accepted: 2148   Special Judge

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts,
the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number
of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space
separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit
neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets).
If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

Source

题意:n个数任取c个且是c的倍数的一种取法,输出取的元素的下标
题解:和上一篇原理一样
#include<stdio.h>
#include<string.h>
long long c[100005],mark[100005],x;
int main()
{
    int m,n,i,j,flag,temp;

    while(scanf("%d%d",&m,&n)&&n+m)
    {
        memset(mark,0,sizeof(mark));
        for(c[0]=flag=0,i=1;i<=n;i++)
        {
            scanf("%I64d",&x);
            if(flag) continue;
            c[i]=c[i-1]+x;
            temp=c[i]%m;
            if(temp==0)
            {
                for(j=1;j<i;j++) printf("%d ",j);
                printf("%d\n",j);
                flag=1;
            }
            else if(mark[temp])
            {
                for(j=mark[temp]+1;j<i;j++) printf("%d ",j);
                printf("%d\n",j);
                flag=1;
            }
            mark[temp]=i;
        }
    }

    return 0;
}

抱歉!评论已关闭.