现在的位置: 首页 > 综合 > 正文

Minesweeper UVA- 这尼玛坑爹的空行

2014年10月24日 ⁄ 综合 ⁄ 共 2180字 ⁄ 字号 评论关闭

UVA上的大水,和扫雷游戏一样,结果WA了2次!!!!就是因为没有处理好结尾空行的问题,也算是个教训吧,再一次被UVA强大的后台检测给黑到了

注意的就是把数组开大一点,然后空行的换是第二字数据输出 空行+数据,而不是一组数据出来之后直接出空行,这样的话数据结尾会多一个空行,就会WA

The Problem

Have you ever played Minesweeper? It's a cute little game which comes within a certain Operating System which name we can't really remember. Well, the goal of the game is to find where are all the mines within a MxN field. To help
you, the game shows a number in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4x4 field with 2 mines (which are represented by an * character):

*...
....
.*..
....

If we would represent the same field placing the hint numbers described above, we would end up with:

*100
2210
1*10
1110

As you may have already noticed, each square may have at most 8 adjacent squares.

The Input

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m <= 100) which stands for the number of lines and columns of the field respectively. The next n lines contains
exactly m characters and represent the field. Each safe square is represented by an "." character (without the quotes) and each mine square is represented by an "*" character (also without the quotes). The first field line where n = m = 0 represents the end
of input and should not be processed.

The Output

For each field, you must print the following message in a line alone:

Field #x:

Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the "." characters replaced by the number of adjacent mines to that square. There must be an empty line between field
outputs.

Sample Input

4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

Sample Output

Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100


#include<stdio.h>
#include<string.h>
#define MAX_SIZE 100 + 10
int main()
{
    char maps[MAX_SIZE][MAX_SIZE];
    int i,j,m,n,sum;
    int cases=1;
    for(;scanf("%d%d",&m,&n);)
    {
        memset(maps,'.',sizeof(maps));
        if(!m&&!n)
          break;
        getchar();
        for(i=1;i<=m;i++)
           {
            for(j=1;j<=n;j++)
             maps[i][j]=getchar();
             getchar();
           }
        if(cases>1)printf("\n");
        printf("Field #%d:\n",cases);
        for(i=1;i<=m;i++)
        {
            for(j=1;j<=n;j++)
        {
            sum=0;
            if(maps[i][j]=='*')
                printf("*");
            else
            {
                if(maps[i+1][j]=='*')
                    sum++;
                if(maps[i-1][j]=='*')
                    sum++;
                if(maps[i][j+1]=='*')
                    sum++;
                if(maps[i][j-1]=='*')
                    sum++;
                if(maps[i+1][j+1]=='*')
                    sum++;
                if(maps[i+1][j-1]=='*')
                    sum++;
                if(maps[i-1][j+1]=='*')
                    sum++;
                if(maps[i-1][j-1]=='*')
                    sum++;
                printf("%d",sum);
            }
        }
        printf("\n");
        }
        cases++;
    }
    return 0;
}


抱歉!评论已关闭.