现在的位置: 首页 > 综合 > 正文

UVA 10369 – Arctic Network(最小生成树)

2014年10月31日 ⁄ 综合 ⁄ 共 2119字 ⁄ 字号 评论关闭

Problem C: Arctic Network

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will
have a radio transceiver and some outposts will in addition have a satellite channel.

Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which
depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow,
giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000). For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

题意:有m个卫星,n个站点,卫星可以不用代价连,剩下要用无线电连,求无线电连接中最大距离的最小、

思路:最小生成树,从最小边开始加入,这样第n - m 条边的权值就是答案

代码:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;

const int MAXN = 505;
int t, m, n, i, j, Mnum, parent[MAXN];
double x[MAXN], y[MAXN], sum;

struct Map {
	int a, b;
	double value;
} M[MAXN * MAXN];

int cmp(Map a, Map b) {
	return a.value < b.value;
}

int find(int x) {
	if (x == parent[x])
		return x;
	else 
		x = find(parent[x]);
}

int main() {
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d", &m, &n);
		Mnum = 0;
		sum = 0;
		for (i = 0; i <= n; i ++)
			parent[i] = i;
		for (i = 1; i <= n; i ++)
			scanf("%lf%lf", &x[i], &y[i]);
		for (i = 1; i <= n; i ++)
			for (j = i + 1; j <= n; j ++) {
				M[Mnum].a = i;
				M[Mnum].b = j;
				M[Mnum++].value = sqrt((x[i] - x[j]) * (x[i] - x[j]) + (y[i] - y[j]) * (y[i] - y[j]));
			}
		sort(M, M + Mnum, cmp);
		int nnum = 0;
		double ans;
		for (i = 0; i < Mnum; i ++) {
			int pa = find(M[i].a);
			int pb = find(M[i].b);
			if (pa != pb) {
				parent[pa] = pb;
				sum += M[i].value;
				nnum ++;
				if (nnum == n - m) {
					ans = M[i].value;
					break;
				}
			}
		}
		printf("%.2lf\n", ans);
	}
	return 0;
}

抱歉!评论已关闭.