现在的位置: 首页 > 综合 > 正文

uva 1450 – Airport(贪心+二分)

2014年10月31日 ⁄ 综合 ⁄ 共 2840字 ⁄ 字号 评论关闭

A big city has an international airport handling 40 million passengers a year. But this is notorious as one of the most congested airports in the world. In this airport, there is only one landing strip
as in the above figure. Therefore the landing strip is always crowded with a lot of aircrafts waiting for a takeoff. There are two ways, say west-road W and east-road E, to approach the landing strip.
The aircrafts are waiting for a takeoff on the two roads as in the above figure.

\epsfbox{p4725.eps}

At each time t, an arbitrary number of aircrafts arrive on the roads W and E. Each aircraft arriving on W or E at
time t receives a rank, which is equal to the number of the waiting aircrafts on the same road to precede it. Then the one of W and E is chosen by a control tower, and
the most front aircraft on the road leaves the ground. Given an information of the arriving aircrafts at times, we are concerned in the takeoff schedule of the control tower to minimize the maximum rank of the aircrafts.

    roads    
      W E
times        
  1   A1A2A3 B1B2
  2     B3B4B5
  3   A4A5  

For example, the above table represents the aircrafts arriving on the roads W and E at each time. At time 1, the aircrafts A1A2 and A3receive
the ranks 0, 1 and 2, respectively, and the aircrafts B1 and B2 receive the ranks 0 and 1, respectively. Then the control tower allows the aircraft B1 on
the road E to take off, and B1 leaves the ground. At time 2, the aircrafts B3B4, and B5 receive
the ranks 1, 2 and 3, respectively. Then A1 on the road W is allowed to take off, and it leaves the ground. At time 3, the aircrafts A4 and A5 receive
the ranks 2 and 3, respectively. So the maximum rank of the aircrafts is 3, and this is the minimum of the maximum rank over all the possible takeoff schedules.

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given on the first
line of the input. The first line of each test case contains an integer n (1$ \le$n$ \le$5000) ,
the number of times. In the next n lines of each test case, the i-th line contains two integer numbers ai and bi,
representing the number of arriving aircrafts on the road W and E, respectively, at time i, where 0$ \le$aibi$ \le$20.

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line contains the minimum of the maximum rank over all the possible takeoff schedules.

The following shows sample input and ouput for three test cases.

Sample Input 

3 
1 
1 1
3 
3 2
0 3
2 0
6 
0 1
1 1
1 2
1 1
1 1
6 0

Sample Output 

0 
3 
5

题意:有一个飞机场,有两个通道,每个通道都可以进飞机,然后每次最多发射一辆飞机,然后求最多停滞在通道的飞机数的最小值。

思路:二分停滞的飞机,然后去判断,判断的时候,要注意如果通道的飞机数为0,那么是不能发射的。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int N = 5005;

int t, n, a[N], b[N];

void init() {
    scanf("%d", &n);
    for (int i = 0; i < n; i ++)
	scanf("%d%d", &a[i], &b[i]);
}

bool judge(int mid) {
    int an = 0, bn = 0, needa, needb, have = 0;
    for (int i = 0; i < n; i ++) {
	an += a[i]; bn += b[i];
	needa = max(an - mid, 0);
	needb = max(bn - mid, 0);
	if (needa + needb > have) return false;
	if (an == 0 && bn > 0)
	    bn--;
	else if (bn == 0 && an > 0)
	    an--;
	else if (an > 0 && bn > 0 && an + bn > have)
	    have++;
    }
    return true;
}

int solve() {
    int l = 0, r = 100000;
    while (l < r) {
	int mid = (l + r) / 2;
	if (judge(mid)) r = mid;
	else l = mid + 1;
    }
    return r == 0 ? 0 : r - 1;
}

int main() {
    scanf("%d", &t);
    while (t--) {
	init();
	printf("%d\n", solve());
    }
    return 0;
}

抱歉!评论已关闭.