现在的位置: 首页 > 综合 > 正文

HDU 2000 ASCII码排序

2014年11月11日 ⁄ 综合 ⁄ 共 608字 ⁄ 字号 评论关闭
Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
 
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
 
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
 
Sample Input
qwe asd zxc
 
Sample Output
e q w a d s c x z
#include<stdio.h>
int main()
{
	char a,b,c,q;
	while(scanf("%c%c%c",&a,&b,&c)!=EOF)
	{
		getchar();
	if(a>b)
	{
		q=a;
		a=b;
		b=q;
	}
	if(a>c)
	{
		q=a;
		a=c;
		c=q;
	}
	if(b>c)
	{
		q=b;
		b=c;
		c=q;
	}
	printf("%c %c %c\n",a,b,c);
	}
	return 0;
}

#include<stdio.h>
 #include<algorithm>
using namespace std;
 char word[10];
 bool cmp( char a , char b )
 {
 return   b>a;
 }
 int main()
 {
     int i,n;
     scanf("%d",&n);
     while(n--)
	 {
         scanf("%s",word);
        sort(word,word+3,cmp);
        for(i=0;i<2;i++)
             printf("%c ",word[i]);
		printf("%c",word[2]);
		printf("\n");
    }
 return 0;
 }

抱歉!评论已关闭.