现在的位置: 首页 > 综合 > 正文

HDU 1170Balloon Comes!

2014年11月11日 ⁄ 综合 ⁄ 共 1122字 ⁄ 字号 评论关闭

Description

The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result. 
Is it very easy? 
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
 

Input

Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of
course, we all know that A and B are operands and C is an operator. 
 

Output

For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
 

Sample Input

4 + 1 2 - 1 2 * 1 2 / 1 2
 

Sample Output

3 -1 2 0.50
注意输入字符的时候之前加getchar().
#include<stdio.h>
int main()
{
	int t,i,a,b;
	char c;
	double n;
	scanf("%d",&t);
	while(t--)
	{
		getchar();
		scanf("%c %d %d",&c,&a,&b);
		if(c=='+')
			printf("%d\n",a+b);
		else if(c=='-')
			printf("%d\n",a-b);
		else if(c=='*')
			printf("%d\n",a*b);
		else
		{
			if(a%b==0)
				printf("%d\n",a/b);
			else
				printf("%.2lf\n",(double)a/b);
		}
	}
	return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.