现在的位置: 首页 > 综合 > 正文

uva 10382 – Watering Grass(贪心)

2014年11月12日 ⁄ 综合 ⁄ 共 1704字 ⁄ 字号 评论关闭
文章目录

题目链接http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1323

Problem E
Watering Grass
Input:
standard input
Output: standard output
Time Limit: 3 seconds

n sprinklers are installed in a horizontal strip of grass l meters long andw meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from
the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

Input

Input consists of a number of cases. The first line for each case contains integer numbersn,l andw with
n <= 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

Sample Output

6

2

-1

 

面积覆盖转化成经典的区间覆盖问题,贪心

 

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;

struct Node{
    double s,e;
}a[10005];

bool cmp(Node x, Node y){
    return x.s < y.s;
}

int main(){
    int n,l,w,ans;
    int p,r;
    int i,j;
    double pos;//实时起点

    while(scanf("%d%d%d",&n,&l,&w) != EOF){
        ans = 0;
        for(i = 0;i < n;i++){
            cin >> p >> r;
            //除掉完全没用的
            if(r < w / 2.0){
                a[i].s = l+100;
                a[i].e = l+100;
                continue;
            }
            double tem = sqrt((double)r * r - (double)w * w  / 4.0);
            a[i].e = p + tem;
            a[i].s = p - tem;
        }
        sort(a,a+n,cmp);
        double max;
        int tag = 1;
        int last = 0;pos = 0;
        while(pos < l ){
            max = -1;
            for(i = last;(a[i].s < pos || abs(a[i].s - pos) < 1e-6)&& i < n;i++){
                if(a[i].e > max){
                    max = a[i].e;
                }
            }
            if(max == -1){
                tag = 0;
                break;
            }
            pos = max;
            last = i;
            ans++;
        }
        if(tag == 0)
            cout << -1 << endl;
        else
            cout << ans << endl;
    }

    return 0;
}

 


(Regionals 2002 Warm-up Contest, Problem setter: Piotr Rudnicku)

抱歉!评论已关闭.