现在的位置: 首页 > 综合 > 正文

HDU4089-Activation(概率DP)

2014年11月13日 ⁄ 综合 ⁄ 共 3108字 ⁄ 字号 评论关闭

Activation

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1332    Accepted Submission(s): 501

Problem Description
After 4 years' waiting, the game "Chinese Paladin 5" finally comes out. Tomato is a crazy fan, and luckily he got the first release. Now he is at home, ready to begin his journey.
But before starting the game, he must first activate the product on the official site. There are too many passionate fans that the activation server cannot deal with all the requests at the same time, so all the players must wait in queue. Each time, the server
deals with the request of the first player in the queue, and the result may be one of the following, each has a probability:
1. Activation failed: This happens with the probability of p1. The queue remains unchanged and the server will try to deal with the same request the next time.
2. Connection failed: This happens with the probability of p2. Something just happened and the first player in queue lost his connection with the server. The server will then remove his request from the queue. After that, the player will immediately connect
to the server again and starts queuing at the tail of the queue.
3. Activation succeeded: This happens with the probability of p3. Congratulations, the player will leave the queue and enjoy the game himself.
4. Service unavailable: This happens with the probability of p4. Something just happened and the server is down. The website must shutdown the server at once. All the requests that are still in the queue will never be dealt.
Tomato thinks it sucks if the server is down while he is still waiting in the queue and there are no more than K-1 guys before him. And he wants to know the probability that this ugly thing happens.
To make it clear, we say three things may happen to Tomato: he succeeded activating the game; the server is down while he is in the queue and there are no more than K-1 guys before him; the server is down while he is in the queue and there are at least K guys
before him.
Now you are to calculate the probability of the second thing.
 

Input
There are no more than 40 test cases. Each case in one line, contains three integers and four real numbers: N, M (1 <= M <= N <= 2000), K (K >= 1), p1, p2, p3, p4 (0 <= p1, p2, p3, p4 <= 1, p1 + p2 + p3 + p4 = 1), indicating there
are N guys in the queue (the positions are numbered from 1 to N), and at the beginning Tomato is at the Mth position, with the probability p1, p2, p3, p4 mentioned above.
 

Output
A real number in one line for each case, the probability that the ugly thing happens.
The answer should be rounded to 5 digits after the decimal point.
 

Sample Input
2 2 1 0.1 0.2 0.3 0.4 3 2 1 0.4 0.3 0.2 0.1 4 2 3 0.16 0.16 0.16 0.52
 

Sample Output
0.30427 0.23280 0.90343
 
迭代终于有一点感觉了!
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;

const double eps = 1e-7;
const int maxn = 2000+10;
int n,m,k;
double dp[maxn][maxn];
double p1,p2,p3,p4;
double A[maxn];
double Pow[maxn];

int main(){
    while(~scanf("%d%d%d%lf%lf%lf%lf",&n,&m,&k,&p1,&p2,&p3,&p4)){
        if(p4<eps) {
            printf("0.00000\n");
            continue;
        }
        double p21 = p2/(1-p1);
        double p31 = p3/(1-p1);
        double p41 = p4/(1-p1);
        Pow[0] = 1;
        for(int i = 1; i <= n; i++) Pow[i] = Pow[i-1]*p21;

        dp[1][1] = p41/(1-p21);
        for(int i = 2; i <= n; i++){
            A[1] = p41;
            for(int j = 2; j <= i; j++){
                A[j] = p31*dp[i-1][j-1];
                if(j<=k) A[j] += p41;
            }
            double t = A[1]*Pow[i-1];
            for(int j = 2; j <= i; j++){
                t += A[j]*Pow[i-j];
            }
            dp[i][i] = t/(1-Pow[i]);
            dp[i][1] = p21*dp[i][i]+p41;
            for(int j = 2; j < i; j++)
                dp[i][j] = p21*dp[i][j-1]+A[j];
        }
        printf("%.5lf\n",dp[n][m]);
    }
    return 0;
}

抱歉!评论已关闭.