现在的位置: 首页 > 综合 > 正文

UVA 10041 – Vito’s Family

2014年11月21日 ⁄ 综合 ⁄ 共 1275字 ⁄ 字号 评论关闭

  Problem C: Vito's family 


Background 

The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house
close to them.

Problem 

Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.

Input 

The input consists of several test cases. The first line contains the number of test cases.

For each test case you will be given the integer number of relatives r ( 0 < r < 500) and the street numbers (also integers) $s_1, s_2, \ldots, s_i, \ldots, s_r$ where
they live ( 0 < si < 30000 ). Note that several relatives could live in the same street number.

Output 

For each test case your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers si and sj is dij=
|
si-sj|.

Sample Input 

2
2 2 4 
3 2 4 6

Sample Output 

2
4
早起一水啊!
直接排序找到中点,然后算一遍距离即可
#include<cstdio>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<algorithm>
#include<cmath>
#include <cstring>
#include <queue>
using namespace std;
#define eps 1e-20
#define MAXN 2000010
int a[550];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i = 0 ; i < n ; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a , a + n);
        int d;
        if(n % 2 )d =  a[n / 2] ;
        else d = a[n / 2 - 1] ;
        int ans = 0;
        for(int i = 0 ; i < n ; i++)
        {
            ans += abs(d - a[i]);
        }
        cout << ans << endl;
    }

    return 0;
}

抱歉!评论已关闭.