现在的位置: 首页 > 综合 > 正文

Trees on the level

2015年07月12日 ⁄ 综合 ⁄ 共 3418字 ⁄ 字号 评论关闭

Background

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on
fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256
nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level
k are printed before all nodes at level k+1.

For example, a level order traversal of the tree

picture28

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where
n is the value at the node whose path from the root is given by the string
s. A path is given be a sequence of L's and R's where
L
indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string
indicates the path from the root to itself. A binary tree is considered to be
completely specified
if every node on all root-to-node paths in the tree is given a value exactly once.

The Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No
whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given
a value more than once, then the string ``not complete'' should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

# include <iostream>
# include <cstring>
# include <queue>
# include <cstdio>
# include <vector>
# include <algorithm>
using namespace std;

char s[300];
bool failed;

//建立树的结构体;
struct Node
{
	bool have_value;    //判断当前结点有没有值:
	int v;
	Node *left,*right;  //指针,指向当前结点的左子树和右子树;
	Node():have_value(false),left(NULL),right(NULL){}    //结点的初始化;
};

Node* root;   //建立指向根结点的指针;
Node* newnode() { return new Node(); }

void addnode(int v,char *s)     //新建结点:
{
	int n =strlen(s);      //将‘,’以后的长度赋值给n;
	Node *u=root;          //将指针指向根结点;
	for(int i=0;i<n;i++)
		if(s[i]=='L')  //判断为左,便将当前指针指向它的左子树;
		{
			if(u->left== NULL )    u->left=newnode();    //判断当前结点的左子树是否存在;如不存在,则新                        u=u->left;                                   //建结点:
		}
		else if(s[i]=='R')
		{
			if(u->right== NULL )  u->right=newnode();
			u=u->right;
		}
	if(u->have_value)   failed=true;
	u->v=v;
	u->have_value=true;
}

void remove_tree(Node *u)
{
	if(u ==NULL)    return;
	remove_tree(u->left);
	remove_tree(u->right);
	delete u;
}

bool read_in()
{
	failed=false;
	remove_tree(root);    //用指令new开辟的空间,所以要删除;
	root = newnode();
	for(;;)
	{
		if(scanf("%s",s)!=1) return false;
		if(!strcmp(s,"()")) break;
		int v;
		sscanf(&s[1],"%d",&v);    //将值取出:
		addnode(v,strchr(s,',')+1);     //strchr()找到字符出现的位置:
	}
	return true;
}

bool dfs(vector < int > & ans)    //来判断树有没有完整,然后进行层次遍历:
{
	queue <Node *> q;
	ans.clear();
	q.push(root);
	while(!q.empty())
	{
		Node *u=q.front(); q.pop();
		if(!u->have_value)    return false;
		ans.push_back(u->v);
		if(u->left!=NULL) q.push(u->left);
		if(u->right!=NULL) q.push(u->right);
	}
	return true;
}

int main()
{
    //freopen("a.txr","r",stdin);
	vector < int > ans;
	while(read_in())
	{
		if(!dfs(ans))    failed=1;
		if(failed)    printf("not complete\n");
		else
		{
			for(int i=0;i<ans.size();i++)
			{
 				if(i!=0)    printf(" ");
				printf("%d",ans[i]);
			}
			printf("\n");
		}
	}
	return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.