现在的位置: 首页 > 综合 > 正文

Find The Multiple(POJ 1426)

2015年11月21日 ⁄ 综合 ⁄ 共 917字 ⁄ 字号 评论关闭

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

参考网站:http://blog.csdn.net/lyy289065406/article/details/6647917

#include<iostream>
using namespace std;
int mod[1048578];
int main(){
    int n,m,pm;
    while(cin>>n,n){
        mod[1]=1%n;
        m=10%n;
        int i;
        for(i=2;mod[i-1];i++){
            mod[i]=(mod[i/2]*m+i%2)%n;
        }
        i--;
        pm=1;
        while(i){
            mod[pm++]=i%2;
            i/=2;
        }
        while(--pm) cout<<mod[pm];
        cout<<endl;
    }
}

抱歉!评论已关闭.