现在的位置: 首页 > 综合 > 正文

HDU1024 Max Sum Plus Plus 【DP】

2015年11月29日 ⁄ 综合 ⁄ 共 1642字 ⁄ 字号 评论关闭

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17164    Accepted Submission(s): 5651
Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

 

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.

/*
** dp[i][j]表示以第i个数字结尾且选定并分成j份能得到的最大值,转移方程为
** dp[i][j] = max(dp[i-1][j], max(dp[1...i-1][j-1])) + arr[i];
** 如果开二维数组的话内存会超,所以得用滚动数组省空间,preMax[j]保存
** 上一轮得到的dp[1...i][j]中的最大值,ans每次读取当前dp数组最大值
** 用以更新preMax数组,最后一轮循环后ans保存的就是答案。
*/

#include <stdio.h>
#include <string.h>

#define maxn 1000010
#define inf 0x7fffffff

int dp[maxn], preMax[maxn], arr[maxn];

int max(int a, int b) {
	return a > b ? a : b;
}

int main() {
	int n, m, i, j, ans;
	while(scanf("%d%d", &n, &m) == 2) {
		for(i = 1; i <= m; ++i) {
			scanf("%d", &arr[i]);
			preMax[i] = dp[i] = 0;
		}
		preMax[0] = dp[0] = 0;
		for(j = 1; j <= n; ++j) { // 分成j份
			ans = -inf;
			for(i = j; i <= m; ++i) {
				dp[i] = max(dp[i-1], preMax[i-1]) + arr[i];
				preMax[i-1] = ans;
				ans = max(ans, dp[i]);
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}

抱歉!评论已关闭.