现在的位置: 首页 > 综合 > 正文

HDU1102 Constructing Roads 【最小生成树Prim】

2015年12月04日 ⁄ 综合 ⁄ 共 1794字 ⁄ 字号 评论关闭

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13756    Accepted Submission(s): 5223

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B,
or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

 

 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within
[1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

 

 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

 

Sample Output
179

这题坑人的地方就是题目实际上是多组数据的...

 

#include <stdio.h>
#include <string.h>
#define maxn 102

int map[maxn][maxn];
bool vis[maxn];

void Prim(int n)
{
	int i, j, len = 0, count = 0, tmp, u;
	vis[1] = 1;
	while(count < n - 1){
		for(i = 1, tmp = -1; i <= n; ++i){
			if(!vis[i]) continue;
			for(j = 1; j <= n; ++j)
				if(!vis[j] && (map[i][j] < tmp || tmp == -1)){
					tmp = map[i][j]; u = j;
				}
		}
		if(tmp != -1){
			++count;
			vis[u] = 1;
			len += tmp;
		}
	}
	printf("%d\n", len);
}

int main()
{
	//freopen("in.txt", "r", stdin);
	//freopen("out.txt", "w", stdout);
	int n, q, a, b, i, j;
	while(scanf("%d", &n) != EOF){
		memset(vis, 0, sizeof(vis));
		for(i = 1; i <= n; ++i)
			for(j = 1; j <= n; ++j)
				scanf("%d", &map[i][j]);
		scanf("%d", &q);
		while(q--){
			scanf("%d%d", &a, &b);
			map[a][b] = map[b][a] = 0;
		}
		Prim(n);
	}
	return 0;
}

 

抱歉!评论已关闭.