现在的位置: 首页 > 综合 > 正文

HDU3199 Hamming Problem 【数论】

2015年12月06日 ⁄ 综合 ⁄ 共 1063字 ⁄ 字号 评论关闭

Hamming Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 703    Accepted Submission(s): 289
Problem Description
For each three prime numbers p1, p2 and p3, let's define Hamming sequence Hi(p1, p2, p3), i=1, ... as containing in increasing order all the natural numbers whose only prime divisors are p1, p2 or p3.

For example, H(2, 3, 5) = 2, 3, 4, 5, 6, 8, 9, 10, 12, 15, 16, 18, 20, 24, 25, 27, ...

So H5(2, 3, 5)=6.

 

Input
In the single line of input file there are space-separated integers p1 p2 p3 i.
 

Output
The output file must contain the single integer - Hi(p1, p2, p3). All numbers in input and output are less than 10^18.
 

Sample Input
7 13 19 100
 

Sample Output
26590291
 

Source

#include <stdio.h>
#define maxn 10000

__int64 dp[maxn] = {1, 1};
__int64 a0, b0, c0, a, b, c;

__int64 min(__int64 u, __int64 v, __int64 x)
{
    __int64 tmp = u;
    if(tmp > v) tmp = v;
    if(tmp > x) tmp = x;

    if(tmp == u) ++a;
    if(tmp == v) ++b;
    if(tmp == x) ++c;
    
    return tmp;
}

int main()
{
    __int64 i, n;
    while(scanf("%I64d%I64d%I64d%I64d", &a0, &b0, &c0, &n) != EOF){
        a = b = c = 0; dp[0] = 1;
        for(i = 1; i <= n; ++i)
            dp[i] = min(dp[a]*a0, dp[b]*b0, dp[c]*c0);
        printf("%I64d\n", dp[n]);
    }
    return 0;
}

抱歉!评论已关闭.