现在的位置: 首页 > 综合 > 正文

HDOJ 题目3268 Silver Cow Party(最短路)

2015年12月10日 ⁄ 综合 ⁄ 共 1979字 ⁄ 字号 评论关闭
Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13199   Accepted: 5942

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional
(one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: AiBi, and Ti. The described road runs from farm Ai to farm Bi,
requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

题目大意:问最大的最短路径的环,
ac代码
#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
#define max(a,b) (a>b?a:b)
int map1[1010][1010],map2[1010][1010],v[1010],dis1[1010],dis2[1010],n;
void djs(int x,int map[1010][1010],int *dis)
{
	int i,j,k,min=INF,flag;
	for(i=1;i<=n;i++)
	{
		dis[i]=map[x][i];
		v[i]=0;
	}
	v[x]=1;
	for(i=1;i<=n;i++)
	{
		min=INF;
		flag=-1;
		for(j=1;j<=n;j++)
		{
			if(!v[j]&&dis[j]<min)
			{
				min=dis[j];
				flag=j;
			}
		}
		v[flag]=1;
		for(j=1;j<=n;j++)
		{
			if(!v[j]&&dis[flag]+map[flag][j]<dis[j])
				dis[j]=dis[flag]+map[flag][j];
		}
	//	printf("%d\n",n);
	}
}
int main()
{
	int m,x;
	while(scanf("%d%d%d",&n,&m,&x)!=EOF)
	{
		int i,ans=0,j;
		for(i=0;i<=n;i++)
		{
			for(j=0;j<=n;j++)
				map1[i][j]=map2[i][j]=INF;
			map1[i][i]=map2[i][i]=0;
		}
		while(m--)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			if(c<map1[a][b])
				map1[a][b]=c;
			if(c<map2[b][a])
				map2[b][a]=c;
		}
		djs(x,map1,dis1);
		djs(x,map2,dis2);
		for(i=1;i<=n;i++)
		{
			ans=max(ans,dis1[i]+dis2[i]);
	//		printf("%d %d\n",dis1[i],dis2[i]);
		}
		printf("%d\n",ans);
	}
}

抱歉!评论已关闭.