现在的位置: 首页 > 综合 > 正文

POJ 题目2249 Binomial Showdown(数学)

2015年12月10日 ⁄ 综合 ⁄ 共 972字 ⁄ 字号 评论关闭
Binomial Showdown
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18358   Accepted: 5600

Description

In how many ways can you choose k elements out of n elements, not taking order into account? 
Write a program to compute this number.

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two integers n (n>=1) and k (0<=k<=n). 
Input is terminated by two zeroes for n and k.

Output

For each test case, print one line containing the required number. This number will always fit into an integer, i.e. it will be less than 231
Warning: Don't underestimate the problem. The result will fit into an integer - but if all intermediate results arising during the computation will also fit into an integer depends on your algorithm. The test cases will go to the limit. 

Sample Input

4 2
10 5
49 6
0 0

Sample Output

6
252
13983816

Source

ac代码
#include<stdio.h>
#include<string.h>
__int64 c(int a,int b)
{
	__int64 ans=1;
	int i;
	if(b>a/2)
		b=a-b;
	for(i=1;i<=b;i++)
	{
		ans*=(a-i+1);
		ans/=i;
	}
	return ans;
}
int main()
{
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF,a||b)
	{
		printf("%I64d\n",c(a,b));
	}
}

抱歉!评论已关闭.