现在的位置: 首页 > 综合 > 正文

HDOJ 题目3951Coin Game(博弈)

2015年12月13日 ⁄ 综合 ⁄ 共 1625字 ⁄ 字号 评论关闭

Coin Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1219    Accepted Submission(s): 706


Problem Description
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.


The game goes like this: 
Two players start the game with a circle of n coins. 
They take coins from the circle in turn and every time they could take 1~K continuous coins. 
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game. 
Suppose that those two players always take the best moves and never make mistakes. 
Your job is to find out who will definitely win the game.
 


Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=109,1<=K<=10).
 


Output
For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
 


Sample Input
2 3 1 3 2
 


Sample Output
Case 1: first Case 2: second
 


Author
NotOnlySuccess
 


Source
 


Recommend
lcy   |   We have carefully selected several similar problems for you:  3952 3826 3940 3829 3972 
 

思路http://blog.csdn.net/qinmusiyan/article/details/8015614:博弈


 1) 若k=1,则一次只能去翻一枚,奇数先手赢,偶数后手赢。


 2)若k>1:

         

       a: 先手一次翻完,先手赢;

  

       b: 先手不能翻完,第一次必定断环。只要后手一次翻完,或将其分为相等数量的两段,


            之后先手怎么操作后手就怎么操作,后手必赢。

ac代码

#include<stdio.h>
int main()
{
    int t,c=0;
    scanf("%d",&t);
    while(t--)
    {
        int n,k;
        scanf("%d%d",&n,&k);
        if(k>=n)
        {
            printf("Case %d: first\n",++c);
            continue;
        }
        if(k==1)
        {
            if(n%2)
                printf("Case %d: first\n",++c);
            else
                printf("Case %d: second\n",++c);
        }
        else
            printf("Case %d: second\n",++c);
    }
}

抱歉!评论已关闭.