现在的位置: 首页 > 综合 > 正文

HDOJ 题目2132 An easy problem(水题,易错)

2015年12月14日 ⁄ 综合 ⁄ 共 1075字 ⁄ 字号 评论关闭

An easy problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9204    Accepted Submission(s): 2498


Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
  We can define sum(n) as follow:
  if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
  Is it very easy ? Please begin to program to AC it..-_-
 


Input
  The input file contains multilple cases.
  Every cases contain only ont line, every line contains a integer n (n<=100000).
  when n is a negative indicate the end of file.
 


Output
  output the result sum(n).
 


Sample Input
1 2 3 -1
 


Sample Output
1 3 30
 


Author
Wendell
 


Source
 


Recommend
威士忌   |   We have carefully selected several similar problems for you:  2133 2134 2135 2137 2139 
 
ac代码
#include<stdio.h>
#include<string.h>
__int64 sum[100005];
void fun()
{
	__int64 i;//要注意i定义为64位,不懂。。也是醉了
	sum[0]=0;
	for(i=1;i<100005;i++)
	{
		if(i%3==0)
			sum[i]=sum[i-1]+i*i*i;
		else
			sum[i]=sum[i-1]+i;
	}
}
int main()
{
	int n;
	fun();
	while(scanf("%d",&n)!=EOF)
	{
		if(n<0)
			break;
		printf("%I64d\n",sum[n]);
	}
}

抱歉!评论已关闭.