现在的位置: 首页 > 综合 > 正文

HDOJ题目1011 Starship Troopers(树状dp)

2015年12月17日 ⁄ 综合 ⁄ 共 3103字 ⁄ 字号 评论关闭

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11582    Accepted Submission(s): 3197


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some
of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is
one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight
all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the
problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

 


Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines
give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers,
which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

 


Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 


Sample Input
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 


Sample Output
50 7
 


Author
XU, Chuan
 


Source
 


Recommend
JGShining   |   We have carefully selected several similar problems for you:  2415 3033 3449 3535 1074 
 
#include<stdio.h>
#include<string.h>
#include<vector>
#include<string>
#define max(a,b) (a>b?a:b)
using namespace std;
#define INF 0xfffffff
int vis[10010],use[10010],br[10010],dp[1010][1010];
vector<int>list[10010];
int n,m;
void dfs(int u)
{
	int i,j,k;
	vis[u]=1;
	for(i=use[u];i<=m;i++)
	{
		dp[u][i]=br[u];
	}
		for(i=0;i<list[u].size();i++)
		{
			int v=list[u][i];
			if(vis[v])
				continue;
			dfs(v);
			for(j=m;j>=use[u];j--)
			{
				for(k=1;k<=j-use[u];k++)
				{
					//if(j-k>=use[u])
					dp[u][j]=max(dp[u][j],dp[u][j-k]+dp[v][k]);
				}
			}
		}
}
int main()
{
//	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j,k;
		if(n==-1&&m==-1)
		{
			break;
		}
		for(i=0;i<=n;i++)
			list[i].clear();
		for(i=1;i<=n;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			use[i]=(a+19)/20;
			br[i]=b;
		}
		for(i=1;i<=n-1;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			list[a].push_back(b);
			list[b].push_back(a);
		}
		memset(dp,0,sizeof(dp));
		memset(vis,0,sizeof(vis));
		if(m==0)//注意m=0的情况
		{
			printf("0\n");
			continue;
		}
		dfs(1);
		printf("%d\n",dp[1][m]);
	}
}

抱歉!评论已关闭.