现在的位置: 首页 > 综合 > 正文

poj 3253 Fence Repair【哈夫曼树、优先队列】

2015年12月19日 ⁄ 综合 ⁄ 共 2339字 ⁄ 字号 评论关闭

点击打开题目

Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 27599   Accepted: 8983

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤
50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made;
you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will
result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into
16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题目翻译:

FJ需要修补牧场的围栏,他需要 N 块长度为 Li 的木头(N planks of woods)。开始时,FJ只有一块无限长的木板,因此他需要把无限长的木板锯成 N 块长度为 Li 的木板,Farmer
Don提供FJ锯子,但必须要收费的,收费的标准是对应每次据出木块的长度,比如说测试数据中 5 8 8,一开始,FJ需要在无限长的木板上锯下长度 21 的木板(5+8+8=21),第二次锯下长度为 5 的木板,第三次锯下长度为 8 的木板,至此就可以将长度分别为 5 8 8 的木板找出,第一次花费21,第二次花费5,第三次花费8,因此34=21+5+8;

解题思路:对给出的数据放到集合中,每次都找最小的两组,然后取出加和,然后累计花费,再将它们放到集合中,直到最后成对取完。

#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int main()
{
    priority_queue<__int64,vector<__int64>,greater<__int64> >a;
    int n,i;
    __int64 t,t1,s;
    while(scanf("%d",&n)==1){
        while(!a.empty()) a.pop();
        for(i=1;i<=n;i++){
            scanf("%I64d",&t);
            a.push(t);
        }
        s=0;
        while(a.size()>1){
            t=a.top(); a.pop();
            t1=a.top(); a.pop();
            a.push(t1+t);
            s+=t1+t;
        }
        printf("%I64d\n",s);
    }
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.