现在的位置: 首页 > 综合 > 正文

hdu 1019(LCM)

2012年09月13日 ⁄ 综合 ⁄ 共 1253字 ⁄ 字号 评论关闭

求几个数的LCM, 可以知道的是,从第一个开始每两个求一次最小公倍数,然后得到的就是答案。

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20767    Accepted Submission(s): 7739

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

 

Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
 

 

Sample Output
105
10296
 

 

Source
 

 

Recommend
JGShining
 
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;

typedef __int64 LL;

LL GCD(LL x,LL y)
{
    LL tmp;
    while(y!=0)
    {
        tmp=x%y;
        x=y;
        y=tmp;
    }
    return x;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        LL ans=1;
        for(int i=0;i<n;i++)
        {
            LL tmp,k;
            scanf("%I64d",&tmp);
            k=GCD(tmp,ans);
            ans=(tmp*ans)/k;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

 

抱歉!评论已关闭.